Monday, October 7, 2013

Update on FamilySearch's Books Unavailable

Sorry I didn't try this before writing the last blog post on FamilySearch Books unavailable. When I got home from teaching genealogy classes, I had comments that led me to believe that the issue was a browser error. After trying FireFox and Safari, both of them work fine. I cannot run Internet Explorer on my iMac so I couldn't try that, but Google's Chrome definitely does not work. I often have to remind myself, when I have a Web malfunction, to try a different browser. Thanks for the comments and problem solved, I merely have to switch from Chrome to FireFox. This is the second major problem I have had with Chrome this week already and the week is just starting. The other problem involved losing sound in YouTube.com. That turned out to be a conflict with an Adobe add-on.

If you have the problem of very slow or non-existent downloads from FamilySearch.org Books, try a different browser.

2 comments:

  1. Isn't it amazing? This one catches me every time. And I had to switch to Google Chrome to avoid problems on other browsers...grrrr. I didn't know about the sound on You Tube...that might explain a few things to me...sigh...it's not so much that I lost sound...but there was a delay. Thanks for the heads up.

    ReplyDelete
  2. Thanks for the heads up on the loss of sound on You Tube! I have a relatively new MacBook Pro and sometimes the sound works and sometimes it doesn't! Glad to know it's not the computer! I'm a Chrome user but have Firefox loaded and ready now that I know. Thanks!

    ReplyDelete